Slowness and timeouts accessing apps
Resolved
Apr 18, 2024 at 04:43pm UTC
A change released this morning introduced an issue that caused an overload in our servers. We've now implemented a fix and everything should be back to normal.
Thank you for your patience, if you still need any support please contact our team.
Affected services
Updated
Apr 18, 2024 at 01:30pm UTC
We implemented actions to mitigate the issue and systems should be stable now. We are still investigating the root cause.
Affected services
Created
Apr 18, 2024 at 10:01am UTC
Some merchants are currently experiencing slowness and timeouts accessing Instafeed and Juniper. This affects both admin and storefronts. Our team is looking into it.
Affected services